Problem with calls
Incident Report for CallPage
Resolved
Problem has been solved.

Until 3rd January 2018 Caller ID other than CallPage Numbers may not work properly. We suggest to use CallPage Numbers only.

Thank you for your patience.
Posted 6 months ago. Dec 29, 2017 - 11:03 UTC
Identified
We have temporary issues with calls. On some accounts calls are not generated correctly.
Our IT is already working on it.

We apologize for the inconvenience.
Posted 6 months ago. Dec 29, 2017 - 09:25 UTC