Overloaded servers
Incident Report for CallPage
Resolved
Fixed
Posted 3 months ago. Mar 02, 2018 - 10:54 UTC
Identified
Due to overloaded servers some clients may experience problems with logging in and CallPage panel displaying.

We apologize for the inconvenience.
Posted 3 months ago. Mar 02, 2018 - 09:36 UTC