audio quality
Incident Report for CallPage
Resolved
Fixed.
Posted 5 months ago. Jan 23, 2018 - 13:22 UTC
Identified
Due to sudden jump of calls number some clients may experience imperfect audio quality.
We are working on expanding system architecture.

Please be patient.
Posted 5 months ago. Jan 22, 2018 - 10:48 UTC