widget displaying
Incident Report for CallPage
Resolved
Fixed
Posted 5 months ago. Jan 15, 2018 - 15:29 UTC
Identified
On websites using HTTP our widget may not display. This is caused by wrong configuration on our side.
Our IT is already working on it.

We apologize for the inconvenience.
Posted 5 months ago. Jan 15, 2018 - 14:19 UTC