scheduled calls
Incident Report for CallPage
Resolved
This incident has been resolved.
Posted 3 months ago. Feb 28, 2018 - 08:53 UTC
Investigating
Due to server error scheduled calls are not generated automatically.
Our IT is working on it.

W apologize for the inconvenience.
Posted 3 months ago. Feb 26, 2018 - 10:39 UTC