"Failed" calls
Incident Report for CallPage
Resolved
Fixed
Posted 5 months ago. Jan 18, 2018 - 09:29 UTC
Investigating
Some clients may experience problem with calls. Managers do not receive calls which after all are in the panel with status "Failed".

Our IT is working on it.
Estimated deadline is 15 January.

Please be patient.
Posted 5 months ago. Jan 08, 2018 - 12:07 UTC