Scheduled maintance
Incident Report for CallPage
Resolved
This incident has been resolved.
Posted 5 months ago. Mar 26, 2018 - 14:54 UTC
Identified
Service will be going offline at 00:00 GMT+2 time for upgrades. Expected downtime 15-30 minutes. We apologize for any inconveniences it may cause.
Posted 10 months ago. Oct 11, 2017 - 09:51 UTC