Calls quality
Incident Report for CallPage
Resolved
Fixed.
Posted 7 months ago. Feb 13, 2018 - 10:03 UTC
Identified
Due to the work being carried out some clients may experience imperfect audio quality.

We apologize for the inconvenience
Posted 8 months ago. Jan 31, 2018 - 09:59 UTC