CallPage App
Incident Report for CallPage
Resolved
Fixed.
Posted 8 months ago. Feb 09, 2018 - 13:37 UTC
Monitoring
Android application update available. Problems related to communication with server are entirely fixed.
Update is required to continue using our app.

IOS app is already updated, but we are waiting for App Store release confirmation.
Posted 8 months ago. Feb 08, 2018 - 11:38 UTC
Identified
CallPage mobile app is temporary unavailable. We are working to fix it ASAP.

We apologize for the inconvenience.
Posted 8 months ago. Feb 07, 2018 - 11:46 UTC