Calls quality
Incident Report for CallPage
Resolved
Fixed.
Posted 2 months ago. Oct 04, 2018 - 09:54 UTC
Investigating
Some clients may experience problems with calls quality.
The issue has been forwarded to our external provider.

We apologize for the inconvenience.
Posted 3 months ago. Sep 28, 2018 - 13:52 UTC