Calls through CallPage
Incident Report for CallPage
Resolved
This incident has been resolved.
Posted 5 months ago. Mar 26, 2018 - 14:55 UTC
Monitoring
Due to overloaded servers some clients could experience problems with calls today.

We apologize for the inconvenience.
Posted 6 months ago. Feb 22, 2018 - 15:57 UTC