web hosting service failure
Incident Report for CallPage
Resolved
Fixed
Posted 9 months ago. Dec 18, 2017 - 09:22 UTC
Identified
Because of web hosting service failure some clients may experience problems with calls, recordings and SMS notifications.
Our IT is already working on it.

We apologize for the inconvenience.
Posted 9 months ago. Dec 14, 2017 - 13:39 UTC